Internet Explorer или Microsoft Edge

Internet Explorer
3
Нейтральная
сторона
1
Microsoft Edge
1
Прежде чем писать комментарии или выбрать сторону вы должны авторизироваться!

17-07-2018 09:05 +1

IE не поддерживает новые апи типо уведомлений, захватов экрана, WebRTC, не умеет в хромоподобные расширения и прочее говно.

4 комментария
Egor.Leschev 17-07-2018 09:20 0

cherepets, Есть доводы против IE?

cherepets 17-07-2018 09:42 0

Egor.Leschev, Ну... В 10ке остался только классик IE с его поддержкой сторонних плагинов типо Silverlight и Unity, кастомных панелей и еще пары лишних мелочей. В общем довод против - нельзя пользоваться версией от 8.1, которая была идеальна.

Egor.Leschev 17-07-2018 09:49 0

cherepets, Ты про иммерсивную версию?

cherepets 17-07-2018 09:57 0

Egor.Leschev, Да. Кстати, интересно, а может выдрать как-то appx и установить его на 10?

19-07-2018 14:09 0

MS Edge невозможно установить на нормальные операционные системы => не нужен.

4 комментария
Egor.Leschev 20-07-2018 08:33 0

opera.rulez, Какие операционные системы ты считаешь нормальными? Edge есть под Windows 10 (в том числе и мобильные версии), iOS, Android, Xbox One. IE есть только под Windows 7, 8.1 и 10.

opera.rulez 20-07-2018 15:14 0

Egor.Leschev, Windows 10 — это не операционная система, а программа для отправки разведданных в США с опциональной возможностью что-нибудь запустить: yandex.ru/search/?text=отключение телеме...

Edge для iOS и Android — что это вообще такое? В iOS нельзя сделать браузер на своём движке, модераторы единственного доступного без джейлбрейка магазина пропускают только браузеры, использующие встроенную в iOS модификацию Webkit. Ну ладно, допустим, для Андроида Edge существует.

IE есть только под Windows 7, 8.1 и 10.
IE есть для любой версии Windows. Edge существует для единственной версии Windows.

Egor.Leschev 20-07-2018 15:40 0

opera.rulez, Я имею в виду современный IE. Архаичный есть и под Mac, и под OS/2 и даже под пару Unix-подобных систем. Плюс есть версии Windows, под которые вообще нет IE, это версии в диапазоне 1.01-3.0.

Edge под iOS на WebKit, под Android - на Blink. Но не думаю, что это скажется на вёрстке, так как EdgeHTML совместим с обоими...

opera.rulez 20-07-2018 15:57 +1

Egor.Leschev, Да, к сожалению, для MacOS, MacOSX и под пару Unix-подобных систем есть только IE5, который давно неактуален, потому что не поддерживает ни HTML5, ни CSS3. Для OS/2 IE не выпустили (но можно запустить IE для Win 3.1, потому что встроенная подсистема WIN-OS/2 довольно хорошо эмулирует Windows 3.1). Правда, OS/2 сама неактуальна (в 2005 году компания IBM заявила, что новых версий не будет, хотя до сих пор пытается продавать eComstation).

Но не думаю, что это скажется на вёрстке, так как EdgeHTML совместим с обоими...
Увы, это в теории. На практике Webkit из Сафари немного отличается от Webkit из Хрома (даже от тех версий Хрома, которые были до внедрения Blink). Т. е. на несложных страницах всё выглядит одинаково, а если использовать «продвинутые» возможности, можно нарваться на различия.

21-10-2018 01:37 0

Когда произвёл даунгрейд до 8.1, я прочувствовал всю прелесть IE... Edge это реально очередная хромоподобная хуйня от Microsoft... А ещё он открывает старый интерфейс Ютуба, а сайты не жалуются, что это устаревший браузер.

0 комментариев
17-07-2018 22:58 0

Слишком много доводов против IE:
1. Internet Explorer поддерживает устаревшие технологии по типу ActiveX, с помощью которых можно повредить систему.

2. На Internet Explorer возможно установить тулбары и прочий шлак, который может поставляться вместе со сторонним ПО.

3. Расширения на Internet Explorer слишком тяжёлые и прожорливые, к тому же для их установки требуются административные права.

4. В Internet Explorer слишком сложные настройки, которые могут сильно повлиять на работу операционной системы.

5. Internet Explorer не поддерживает современные биометрические технологии по типу Windows Hello.

6. В Internet Explorer плохо работает очистка истории, к тому же IEшный InPrivate всё ещё оставляет какие-то данные на жёстком диске.

14 комментариев
Jotun 18-07-2018 08:01 +1

Egor.Leschev, Internet Explorer поддерживает устаревшие технологии по типу ActiveX, с помощью которых можно повредить систему.
На которых работает куча корпоративного ПО.
Кстати, повредить систему с тем же успехом можно и через кучу других API, если пользователь дурак.

На Internet Explorer возможно установить тулбары и прочий шлак, который может поставляться вместе со сторонним ПО.
Такое ощущение, что на хромобраузеры люди не ловят тонну малварных расширений.

Egor.Leschev 18-07-2018 22:36 0

Jotun, На которых работает куча корпоративного ПО.
Это временно. Поэтому пока и приходится держать IE в системе, благо его теперь можно безболезненно отключить (другой браузер можно и через Edge скачать).

Кстати, повредить систему с тем же успехом можно и через кучу других API, если пользователь дурак.
Поддержку NPAPI везде где только можно выпилили, Chrome вообще перешёл на PPAPI, под который плагинов, кроме Flash и PDF-читалки нет.

Такое ощущение, что на хромобраузеры люди не ловят тонну малварных расширений.
Там какую-то защиту запилили, чтобы расширения не из магазина не ставились. Хотя если включить режим разработчика, про который не все знают...
В Edge тем более это невозможно, поскольку механизма установки расширений не из Microsoft Store я не нашёл.

opera.rulez 19-07-2018 14:11 0

Egor.Leschev, Поддержку NPAPI везде где только можно выпилили
И это плохо. Хорошо, что хотя бы в Palemoon и в Seamonkey её оставили.

Egor.Leschev 20-07-2018 07:27 +1

opera.rulez, Ещё Basilisk. Насчёт Midori не уверен. Waterfox не подходит, так как он только под 64-бита, и поддерживает только 64-битные плагины, а корпоративному ПО нужны именно 32-битный браузер и 32-битная Java. С Konquerorом геморрой с компиляцией, да и вряд ли он переварит виндовскую яву. Safari только под макинтош, и то они тоже бросают NPAPI. GNOME Web и UZBL только под Unix-подобные системы.

Egor.Leschev 20-07-2018 11:27 +1

Egor.Leschev, Поставил Midori и 4 Fireforkа, чтобы проверить совместимость с Java и NPAPI-плагинами в целом.
Первым я поставил Midori. Прошёл тест с первого пинка. Но меня не устраивает чужеродный интерфейс, не вписывающийся в Windows, и ограниченная функциональность.

Вторым в ход пошёл Basilisk. Ругнулся, что из Firefox выпилили NPAPI с 52-й версии, но я сказал, что использую ESR. Тест пройден. Интерфейс - Firefox версий 29-56.

Третим пошёл SeaMonkey. Здесь ссылка для пользователей ESR-версий пропала, но я её скопировал из Basilisk. Тест пройден. Интерфейс эпохи Netscape Communicator и Mozilla Suite.

Четвёртым пошёл Pale Moon. Здесь уже ссылка была, как и в Basilisk. Тест пройден успешно. Интерфейс а-ля Firefox эпохи 4-28.

Ну и последним я протестировал Waterfox. Он поддерживает NPAPI-плагины, но только 64-битные, так как браузер тоже только 64-битный. А апплет на сайте Java работает только с 32-битной Javой. Тест не пройден.

Egor.Leschev 20-07-2018 11:34 0

Egor.Leschev, Оказывается, Midori не обновлялся аж с 2015 года! Настолько старого браузера я не ставил.

Egor.Leschev 20-07-2018 11:53 0

Egor.Leschev, Из всех перечисленных мне больше всего понравился Basilisk. К тому же у него есть прямая совместимость с WebExtensions, так что
он примет так классические XULовские расширения, так и современные для Quantum.

Egor.Leschev 20-07-2018 12:03 0

Egor.Leschev, На второе место причислю Pale Moon. Всё же хорошо известный браузер в прошаренной среде. Имеется свой собственный источник дополнений.

Третье место присуждается Waterfox, несмотря на фейл в Java. Неплох для использования в целях повседневного сёрфинга. Плюс он довольно безопасный. Причисляет себя к 56 версии, а не к 52, как все остальные.

Ну и последнее место - SeaMonkey. Полный колхоз! Всё туда намешали!

Egor.Leschev 20-07-2018 12:12 0

Egor.Leschev, Кстати, решил попробовать войти в интернет при помощи Thunderbird. Все равно кто-то должен отображать письма, да и дополнения тоже через Gecko и XUL там всё ещё работают.

opera.rulez 20-07-2018 15:30 0

Egor.Leschev, Третим пошёл SeaMonkey... Интерфейс эпохи Netscape Communicator и Mozilla Suite.
Внешний вид легко изменить, например, с помощью расширений Classic Toolbar Buttons, Sea Fox, Classic Firefox theme for SeaMonkey и подобных.

Но вообще странно, что у Фаерфокса внешний вид от версии к версии заметно менялся, а у Seamonkey его решили не трогать.

opera.rulez 20-07-2018 15:34 0

Egor.Leschev, Seamonkey — это комбайн, состоящий из браузера, почтовой программы (аналог Thunderbird) и WYSIWYG-редактора HTML (последний может оказаться полезным тем, кто начинает изучать HTML).

Таким же комбайном были Mozilla Suite и Netscape Communicator (Navigator — это просто браузер, а Communicator — комбайн).

Egor.Leschev 20-07-2018 15:36 0

opera.rulez, Кстати, в ночнушках этой приблуды уже дропнули поддержку NPAPI.

Egor.Leschev 20-07-2018 15:46 0

Egor.Leschev, Похоже, что M.C. Straver (автор Pale Moon и Basilisk) остаётся последним оплотом для пользователей NPAPI-плагинов, а в корпоративной среде они ой как нужны, да и сохранились ещё любители поиграть во Вконтакте, которые сейчас вынуждены играть либо в IE, либо на подыхающей версии Firefox.

Egor.Leschev 21-07-2018 01:18 +1

Egor.Leschev, Waterfox принял WebExtensions. Но и XUL он также переваривает.